Оцените статью: 5 1 1 1 1 1 Рейтинг 5.00 (3 Оценки)

Зачем нужно обновление Joomla

Joomla – стабильная система управления контентом, которая давно завоевала авторитет на рынке. С каждым анонсом новых версий, данная CMS стает более оптимизированной во всем, начиная от безопасности до СЕО.

В данной статье, я хотел бы затронуть тему безопасности Joomla, а именно вопрос – «Почему нужно использовать самые новые версии движка».

В предыдущей статье, были описаны базовые советы по безопасности joomla-сайта. Там было указано, что основным залогом безопасности, является своевременное обновление компонентов (которые были установлены из официальных источников) и самой CMS Joomla.

Начиная с 2008 года (версия 1 и 1.5), Joomla активно эволюционирует. На данный момент, последняя версия – 3.4.

joomla time line

Если Вы решили создать сайт на Joomla, то обязательно используйте самую последнюю версию движка. Это станет основой безопасности Вашего сайта в будущем.

Если же, Вы создавали свой сайт в те времена, когда были версии 1.5, 1.6, 1.7, 2,5, то настоятельно рекомендуем как можно быстрее обновиться к последней версии.
Чем старее версия, тем больше вероятность взлома сайта.

Почему нужно обновить Joomla до последней версии?

Разработчики Joomla всегда усовершенствуют свой продукт, выпуская новые версии. Как правило, новые версии содержат в себе не только новые функции и возможности, но и оптимизацию безопасности.
Вы (те, у кого старые версии Joomla), можете пренебречь новыми возможностями движка, но не стоит пренебрегать безопасностью своего сайта.

Вот немного статистики старых версий Joomla по данным Яндекса:

обновление joomla 3

Точной статистики для версии 2.5 нет. Но, как известно, их тоже не мало.

Версии 1.5, 1.6, 1.7, 2,5 уже не поддерживаются разработчиками, Вы больше не сможете получать патчи обновления для системы и компонентов. Это значит, что у злоумышленников есть много времени, для поиска уязвимостей в устаревших компонентов и движка.
Если найдется какая-то уязвимость, которая может навредить сайту, разработчики больше не смогут ее исправить.
Таким образом, Вы остаетесь в режиме ожидания, когда найдут очередную уязвимости в системе и Ваш сайт будет в числе тех сайтов, которые будут взломаны (а таких не мало).

Уязвимости, которые возможно есть на Вашем сайте

В марте 2014 года была обнаружена уязвимость SQL-внедрения (инъекции), которая позволяла злоумышленникам воровать данные из базы данных и внедрять произвольный код на сайт. Эта информация не сильно распространялась, разработчики просто призвали всех пользователей обновиться до версии 3.2.2.
Подробнее - https://blog.sucuri.net/2014/03/joomla-security-updates-version-2-5-19-and-3-2-3-released.html

В сентябре 2014 года, программист с Германии обнаружил уязвимость в компоненте AkeebaBackup (это один из самых популярных компонентов, который есть практически на каждом сайте). Если верить данным из форумов, Joomla использует такой же код, как и у Akeeba Backup, в стандартном компоненте обновления системы. Это подвергает опасности множество сайтов.

Для устранения уязвимости, нужно обновиться до последней версии Akeeba Backup и обновить Joomla, до версии 3.3.5 и выше.
Подробнее - https://www.akeebabackup.com/home/news/1605-security-update-sep-2014.html

И подобных примеров очень много.

Все уязвимости, по мере их обнаружения, оперативно исправляются разработчиками, Вам же следует регулярно устанавливать новые обновления, тогда Ваш joomla-сайт будет значительно безопаснее.


Похожие статьи

Интересные статьи

Самые читаемые статьи



Рекомендуем хостинг

BeGet

 30 дней бесплатно!

Домены на .ru в подарок